Application Server 7
  1. Application Server 7
  2. AS7-4060

Remote Naming throws org.jboss.remoting3.NotOpenException: Writes closed

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved (View Workflow)
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 7.1.1.Final
    • Component/s: Naming
    • Labels:
      None
    • Similar Issues:
      Show 10 results 

      Description

      I'm getting the following exception with jboss-remote-naming master
      ( commit id https://github.com/jbossas/jboss-remote-naming/commit/57f0a3cdccd8f35e7dbcfb5e169eaf3d97beec52 )

      java.rmi.RemoteException: Call invocation failed; nested exception is: 
      	javax.xml.rpc.JAXRPCException: javax.naming.NamingException: Failed to lookup [Root exception is org.jboss.remoting3.NotOpenException: Writes closed]
      	at org.jboss.ws.core.jaxrpc.client.CallImpl.invokeInternal(CallImpl.java:549)
      	at org.jboss.ws.core.jaxrpc.client.CallImpl.invoke(CallImpl.java:289)
      	at org.jboss.ws.core.jaxrpc.client.PortProxy.invoke(PortProxy.java:157)
      	at $Proxy3.helloEnvEntry(Unknown Source)
      	at org.jboss.test.ws.jaxrpc.enventry.EnvEntryEJBTestCase.testEndpoint(EnvEntryEJBTestCase.java:71)
      Caused by: javax.xml.rpc.JAXRPCException: javax.naming.NamingException: Failed to lookup [Root exception is org.jboss.remoting3.NotOpenException: Writes closed]
      	at org.jboss.test.ws.jaxrpc.enventry.EnvEntryHandler.handleRequestAndResponse(EnvEntryHandler.java:99)
      	at org.jboss.test.ws.jaxrpc.enventry.EnvEntryHandler.handleResponse(EnvEntryHandler.java:61)
      	at org.jboss.ws.core.jaxrpc.handler.HandlerWrapper.handleResponse(HandlerWrapper.java:144)
      	at org.jboss.ws.core.jaxrpc.handler.HandlerChainBaseImpl.handleResponseInternal(HandlerChainBaseImpl.java:377)
      	at org.jboss.ws.core.jaxrpc.handler.HandlerChainBaseImpl.handleResponse(HandlerChainBaseImpl.java:343)
      	at org.jboss.ws.core.jaxrpc.client.CallImpl.callResponseHandlerChain(CallImpl.java:575)
      	at org.jboss.ws.core.CommonClient.invoke(CommonClient.java:409)
      	at org.jboss.ws.core.jaxrpc.client.CallImpl.invokeInternal(CallImpl.java:530)
      	... 36 more
      Caused by: javax.naming.NamingException: Failed to lookup [Root exception is org.jboss.remoting3.NotOpenException: Writes closed]
      	at org.jboss.naming.remote.client.ClientUtil.namingException(ClientUtil.java:36)
      	at org.jboss.naming.remote.protocol.v1.Protocol$1.execute(Protocol.java:101)
      	at org.jboss.naming.remote.protocol.v1.RemoteNamingStoreV1.lookup(RemoteNamingStoreV1.java:76)
      	at org.jboss.naming.remote.client.RemoteContext.lookup(RemoteContext.java:77)
      	at org.jboss.naming.remote.client.RemoteContext.lookup(RemoteContext.java:81)
      	at javax.naming.InitialContext.lookup(InitialContext.java:392)
      	at org.jboss.test.ws.jaxrpc.enventry.EnvEntryHandler.handleRequestAndResponse(EnvEntryHandler.java:82)
      	... 43 more
      Caused by: org.jboss.remoting3.NotOpenException: Writes closed
      	at org.jboss.remoting3.remote.RemoteConnectionChannel.openOutboundMessage(RemoteConnectionChannel.java:107)
      	at org.jboss.remoting3.remote.RemoteConnectionChannel.writeMessage(RemoteConnectionChannel.java:296)
      	at org.jboss.naming.remote.protocol.v1.WriteUtil.write(WriteUtil.java:59)
      	at org.jboss.naming.remote.protocol.v1.Protocol$1.execute(Protocol.java:73)
      	... 48 more
      

        Activity

        Richard Opalka
        added a comment -

        The usecase is identical as descibed in AS7-4056
        i.e. new InitialContext is created/destroyed per test.

        Show
        Richard Opalka
        added a comment - The usecase is identical as descibed in AS7-4056 i.e. new InitialContext is created/destroyed per test.

          People

          • Assignee:
            Stuart Douglas
            Reporter:
            Richard Opalka
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: