Details

    • Similar Issues:
      Show 10 results 

      Description

      Expansion of variables was supported in ejb-jar.xml in previous versions of JBoss. This does not appear to be supported in 7.1. Reference this discussion in the AS forum: https://community.jboss.org/message/717509

        Issue Links

          Activity

          Justin Bertram
          made changes -
          Field Original Value New Value
          Link This issue is related to AS7-3195 [ AS7-3195 ]
          jaikiran pai
          made changes -
          Assignee jaikiran pai [ jaikiran ]
          Brian Stansberry
          made changes -
          Component/s EJB [ 12313806 ]
          SBS JIRA Integration
          made changes -
          jaikiran pai
          added a comment -

          I'm marking this as Open To Community, so that if someone has the time to do this before I get to this (which won't be very soon), they can do so. Feel free to ping of #jboss-as7 IRC of even AS7 dev mailing list https://lists.jboss.org/mailman/listinfo/jboss-as7-dev for any help on getting started with this.

          Show
          jaikiran pai
          added a comment - I'm marking this as Open To Community, so that if someone has the time to do this before I get to this (which won't be very soon), they can do so. Feel free to ping of #jboss-as7 IRC of even AS7 dev mailing list https://lists.jboss.org/mailman/listinfo/jboss-as7-dev for any help on getting started with this.
          jaikiran pai
          made changes -
          Assignee jaikiran pai [ jaikiran ]
          Fix Version/s Open To Community [ 12316379 ]
          Forum Reference https://community.jboss.org/message/721230#721230 https://community.jboss.org/message/721230#721230
          Bartosz Baranowski
          made changes -
          Assignee Bartosz Baranowski [ baranowb ]
          Bartosz Baranowski
          made changes -
          Link This issue depends AS7-2591 [ AS7-2591 ]
          Bartosz Baranowski
          made changes -
          Fix Version/s 7.1.2.Final-redhat1 [ 12319174 ]
          Fix Version/s Open To Community [ 12316379 ]
          Affects Version/s 7.1.1.Final [ 12318875 ]
          Forum Reference https://community.jboss.org/message/721230#721230 https://community.jboss.org/message/721230#721230
          Bartosz Baranowski
          added a comment -

          Assigned to myself since I already handle issues which are related to this propably.

          Show
          Bartosz Baranowski
          added a comment - Assigned to myself since I already handle issues which are related to this propably.
          Christoph Gutmann
          added a comment - - edited

          Expansion of variables in web.xml and jboss-web.xml do not appear to be supported in JBoss 7.1 either (and were in JBoss 5.x). Will expansion of variables in web.xml and jboss-web.xml be supported too in 7.1.2?

          For details please see: http://stackoverflow.com/questions/10032095/references-to-systemproperties-in-web-xml-and-jboss-web-xml-works-in-jboss5-but

          Show
          Christoph Gutmann
          added a comment - - edited Expansion of variables in web.xml and jboss-web.xml do not appear to be supported in JBoss 7.1 either (and were in JBoss 5.x). Will expansion of variables in web.xml and jboss-web.xml be supported too in 7.1.2? For details please see: http://stackoverflow.com/questions/10032095/references-to-systemproperties-in-web-xml-and-jboss-web-xml-works-in-jboss5-but
          Bartosz Baranowski
          added a comment -

          Direct child of issue.

          Show
          Bartosz Baranowski
          added a comment - Direct child of issue.
          Bartosz Baranowski
          made changes -
          Link This issue depends AS7-4479 [ AS7-4479 ]
          Brian Stansberry
          added a comment -

          Assigning to Stuart as I think the work he and John Bailey did covers this; if so he can resolve; if not he can assign back to Bartosz.

          Show
          Brian Stansberry
          added a comment - Assigning to Stuart as I think the work he and John Bailey did covers this; if so he can resolve; if not he can assign back to Bartosz.
          Brian Stansberry
          made changes -
          Assignee Bartosz Baranowski [ baranowb ] Stuart Douglas [ swd847 ]
          Carlo de Wolf
          added a comment -

          There is only missing a test case.

          Show
          Carlo de Wolf
          added a comment - There is only missing a test case.
          Stuart Douglas
          added a comment -

          org.jboss.as.test.smoke.property.EjbDDWithPropertyTestCase

          Show
          Stuart Douglas
          added a comment - org.jboss.as.test.smoke.property.EjbDDWithPropertyTestCase
          Stuart Douglas
          made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Assignee Stuart Douglas [ swd847 ] John Bailey [ johnbailey ]
          Resolution Done [ 1 ]
          Doug Grove
          added a comment -

          I just tried this expansion in: JBoss EAP 6.0.0.GA (AS 7.1.2.Final-redhat-1)

          In my ejb-jar.xml file, I have:

          <message-driven>
          <ejb-name>WebSphereXML</ejb-name>
          <ejb-class>com.redhat.gss.service.ejb30.mdb.WebSphereXML</ejb-class>
          <messaging-type>javax.jms.MessageListener</messaging-type>
          <activation-config>
          <activation-config-property>
          <activation-config-property-name>hostName</activation-config-property-name>
          <activation-config-property-value>$

          {wmq.host}</activation-config-property-value>
          </activation-config-property>
          <activation-config-property>
          <activation-config-property-name>port</activation-config-property-name>
          <activation-config-property-value>${wmq.port}</activation-config-property-value>
          </activation-config-property>

          In my server.log file:


          Caused by: javax.resource.spi.ResourceAdapterInternalException: javax.jms.JMSException: MQJMS2005: failed to create MQQueueManager for '${wmq.host}

          :redhat.queue.manager'
          at com.ibm.mq.connector.ResourceAdapterConnectionPool.allocateConnection(ResourceAdapterConnectionPool.java:297)
          at com.ibm.mq.connector.ResourceAdapterImpl.endpointActivation(ResourceAdapterImpl.java:333)
          at org.jboss.jca.core.rar.EndpointImpl.activate(EndpointImpl.java:164)
          at org.jboss.as.ejb3.component.messagedriven.MessageDrivenComponent.start(MessageDrivenComponent.java:176)
          ... 6 more

          So '$

          {wmq.host}

          ' was not expanded.

          Show
          Doug Grove
          added a comment - I just tried this expansion in: JBoss EAP 6.0.0.GA (AS 7.1.2.Final-redhat-1) In my ejb-jar.xml file, I have: <message-driven> <ejb-name>WebSphereXML</ejb-name> <ejb-class>com.redhat.gss.service.ejb30.mdb.WebSphereXML</ejb-class> <messaging-type>javax.jms.MessageListener</messaging-type> <activation-config> <activation-config-property> <activation-config-property-name>hostName</activation-config-property-name> <activation-config-property-value>$ {wmq.host}</activation-config-property-value> </activation-config-property> <activation-config-property> <activation-config-property-name>port</activation-config-property-name> <activation-config-property-value>${wmq.port}</activation-config-property-value> </activation-config-property> In my server.log file: Caused by: javax.resource.spi.ResourceAdapterInternalException: javax.jms.JMSException: MQJMS2005: failed to create MQQueueManager for '${wmq.host} :redhat.queue.manager' at com.ibm.mq.connector.ResourceAdapterConnectionPool.allocateConnection(ResourceAdapterConnectionPool.java:297) at com.ibm.mq.connector.ResourceAdapterImpl.endpointActivation(ResourceAdapterImpl.java:333) at org.jboss.jca.core.rar.EndpointImpl.activate(EndpointImpl.java:164) at org.jboss.as.ejb3.component.messagedriven.MessageDrivenComponent.start(MessageDrivenComponent.java:176) ... 6 more So '$ {wmq.host} ' was not expanded.
          Show
          Doug Grove
          added a comment - This feature needs to be enabled - turned off by default: https://access.redhat.com/knowledge/docs/en-US/JBoss_Enterprise_Application_Platform/6/html/Administration_and_Configuration_Guide/EnablingDisabling_Descriptor_Based_Property_Replacement.html
          Ninguno Ninguno
          added a comment -

          Expansion wasn't working for jboss-service.xml for a SAR deployment (Jboss AS 7.1.1). Would this be supported with this fix?

          Show
          Ninguno Ninguno
          added a comment - Expansion wasn't working for jboss-service.xml for a SAR deployment (Jboss AS 7.1.1). Would this be supported with this fix?
          Carlo de Wolf
          added a comment -

          Please ask such questions on the JBoss AS 7 forum.

          Do not use a resolved, potential unrelated issue for such discussions.

          Questions regarding EAP 6 are best directed to the Customer Support Portal.

          Show
          Carlo de Wolf
          added a comment - Please ask such questions on the JBoss AS 7 forum . Do not use a resolved, potential unrelated issue for such discussions. Questions regarding EAP 6 are best directed to the Customer Support Portal.

            People

            • Assignee:
              John Bailey
              Reporter:
              Ed Keen
            • Votes:
              8 Vote for this issue
              Watchers:
              15 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: