Arquillian
  1. Arquillian
  2. ARQ-857

Verify Arquillian Core can run on JDK 1.5

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 1.0.0.CR7
    • Fix Version/s: 1.0.0.Final
    • Component/s: Base Implementation
    • Security Level: Public (Everyone can see)
    • Labels:
      None
    • Similar Issues:
      Show 10 results 

      Description

      Setting compiler options target/source to 1.5 is not enough to verify that the code can actually run on JDK 1.5 since it ignores API changes. To avoid forcing developers to have JDK 1.5 installed to compile, we can add e.g. the Animal Sniffer Maven Plugin to verify using usage of JDK based on known api signatures.

        Issue Links

          Activity

          No work has yet been logged on this issue.

            People

            • Assignee:
              Aslak Knutsen
              Reporter:
              Aslak Knutsen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: