Uploaded image for project: 'Arquillian'
  1. Arquillian
  2. ARQ-389

Rename @Target, @Expected, @Run and @DeploymentTarget annotations

    XMLWordPrintable

Details

    • Feature Request
    • Resolution: Done
    • Major
    • 1.0.0.Alpha5
    • 1.0.0.Alpha4
    • Base Implementation
    • None

    Description

      For better consistent naming, we should rename the API annotations:

      • @Run(RunModeType) = @RunAsClient
        • InContainer is extracted from @Deployment(testable) and only possible to override with AS_CLIENT
      • @Expected = @ShouldThrowException
      • @Target = @TargetsContainer("x")
        • Clearify meaning
      • @DeploymentTarget = @OperateOnDeployment
        • Clearify that this test will operate within the context of the @Deployment
      public class TestClass
      {
      
      	@Deployment(name = "dep", testable=false) @ShouldThrowException(Exception.class) @TargetsContainer("x")
      	public JavaArchive create() {}
      
      container x{
      	deployment dep{
      
      	@Test @RunAsClient @OperateOnDeployment("dep") 
      	public void shouldBe() {}
      
      container x{
      	
      	@Test @OperateOnContainer("x")
      	public void shouldBe() {}
      	
      }
      

      Attachments

        Issue Links

          Activity

            People

              aslak@redhat.com Aslak Knutsen
              aslak@redhat.com Aslak Knutsen
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: