AeroGear Push
  1. AeroGear Push
  2. AGPUSH-304

Admin UI should do auth check before rendering content

    Details

    • Similar Issues:
      Show 10 results 

      Description

      When first visiting the app, the main page is rendered and visible for a second or two before the login page appears. This isn't that big of a deal, just weird. The bigger issue is if I am on a page listing a bunch of variant info and then logout, when I hit the back button I see all of that variant info and have plenty of time (1-2 seconds) to take a screenshot before the login screen appears.

        Activity

        Hide
        Lucas Holmquist
        added a comment -

        in https://github.com/lholmquist/aerogear-unified-push-server-admin-ui/commit/f3ca8e2b47a2bad4874445eee9512847a2335121

        i had to disable the "integration" tests. Once i figure out the Ember.run stuff better i will fix that

        Show
        Lucas Holmquist
        added a comment - in https://github.com/lholmquist/aerogear-unified-push-server-admin-ui/commit/f3ca8e2b47a2bad4874445eee9512847a2335121 i had to disable the "integration" tests. Once i figure out the Ember.run stuff better i will fix that

          People

          • Assignee:
            Lucas Holmquist
            Reporter:
            Kris Borchers
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: